Intermittent issue affecting one-way interviews via Browser
Incident Report for Interviewstream
Resolved
This incident has been resolved.
Posted May 29, 2020 - 11:01 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 29, 2020 - 10:11 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 29, 2020 - 10:04 CDT
Update
We are continuing to investigate.

If you encounter an error while completing a one-way interview via Browser, please select via Mobile.
Posted May 28, 2020 - 20:38 CDT
Investigating
We are currently investigating this issue. Please complete interviews during this time via Mobile.
Posted May 28, 2020 - 17:17 CDT
This incident affected: Interviewstream On Demand.