Degraded Performance of Prep Platform
Incident Report for Interviewstream
Resolved
Issue has been identified and resolved.
Posted May 16, 2018 - 13:54 CDT
Investigating
We are investigating why Prep platform is having a degraded performance.

We will update you as soon as we identify the issue.
Posted May 16, 2018 - 13:49 CDT
This incident affected: Interviewstream Prep.