Degraded performance of Prep platform
Incident Report for Interviewstream
Resolved
Issue has been identified and resolved.
Posted Jun 26, 2018 - 16:09 CDT
Investigating
We are currently investigating issue related to Prep platform and degraded performance.

We are going to update this page as soon as we identify an issue.
Posted Jun 26, 2018 - 12:08 CDT
This incident affected: Interviewstream Prep.