Videos will not be available for playback
Incident Report for Interviewstream
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 14:54 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 14, 2020 - 13:30 CDT
Investigating
We are currently experiencing a backlog in the processing of videos in the US.

As a result, interviews will be unplayable until the backlog is processed.
Posted Oct 14, 2020 - 11:55 CDT
This incident affected: Interviewstream On Demand, Interviewstream Connect, Interviewstream Scheduler, and Interviewstream Prep.