Vendor Issue Reported - Audio Dial-In
Incident Report for Interviewstream
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 11:46 CDT
Monitoring
The number is working as expected. We will continue to monitor.
Posted Mar 25, 2020 - 09:34 CDT
Investigating
Our vendor who supports the call-in number 844-326-5588 is currently experiencing an outage. This number is used for one-way interview audio questions or live meeting rooms.

We will continue to monitor the progress of the incident and follow up as we receive additional status updates.
Posted Mar 25, 2020 - 08:36 CDT