Interview Connect - Unable to connect to RIVs Live Interview
Incident Report for Interviewstream
Resolved
This incident has been resolved.
Posted May 25, 2020 - 15:37 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 25, 2020 - 15:29 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 25, 2020 - 14:44 CDT
Investigating
We are currently investigating this issue.
Posted May 25, 2020 - 13:47 CDT
This incident affected: Interviewstream Connect.