Connectivity issues affecting RIVS v3 in Europe
Incident Report for Interviewstream
Resolved
People connecting from Europe should no longer be seeing any issues. Our sincerest apologies for the continued trouble today.
Posted Oct 01, 2018 - 12:15 CDT
Investigating
We're investigating connectivity issues impacting RIVS v3 users located in Europe. Our team is on the case, and we'll have an update for you soon.
Posted Oct 01, 2018 - 12:05 CDT